How to... guides to Walkhighlands

Gpx files in os maps

Gpx files in os maps

Postby makey » Mon Oct 14, 2019 7:29 pm

Hi been using os maps for over 8 months and I import gpx files from walks sections without any problems
Until now over last few weeks any time I try to import into os maps I get file invalid and will not open.
Anyone got a solution for this.
Tried in installing app (still does it)
Tried different gpx files from a vary of walks
Tried on phone and comp
Still can’t get them to work
Any help would be great
Posts: 4
Munros:13   Corbetts:1
Sub 2000:1   
Joined: Mar 7, 2019

Re: Gpx files in os maps

Postby Mal Grey » Mon Oct 14, 2019 8:35 pm

Check with OS customer service; there have been issues with updating the App in the last few weeks, that they're working on solutions for. Could be this.
User avatar
Mal Grey
Posts: 3302
Munros:110   Corbetts:20
Sub 2000:3   Hewitts:113
Wainwrights:71   Islands:5
Joined: Dec 1, 2011
Location: Surrey, probably in a canoe! www.wildernessisastateofmind.co.uk

GPX files

Postby Jordie » Wed Oct 16, 2019 5:00 pm

Hi everyone. I am having problems downloading my box files to OS maps, I have been in touch with OS maps and they said there’s nothing wrong on there end. Not sure what’s going on, always been really simple to get my routes downloaded. Is anyone else having these issues or does anyone know how to resolve this issue please. :D
Mountain Walker
Posts: 1
Joined: Dec 27, 2018

Re: Gpx files in os maps

Postby Paul Webster » Thu Oct 17, 2019 2:09 pm

You can download gpx files from Walkhighlands to your computer or phone. No changes made here. We don't have control beyond that, though if you look earlier in the thread there are others having issues with OS maps opening gpx files at present.
User avatar
Paul Webster
Site Admin
Mountain Walker
Posts: 5302
Munros:282   Corbetts:222
Grahams:66   Donalds:43
Sub 2000:115   Hewitts:133
Wainwrights:134   Islands:92
Joined: Jan 6, 2007
Location: Highland
Walk wish-list

Re: Gpx files in os maps

Postby patbrechin » Tue Oct 22, 2019 8:17 pm

I’m still having this problem and have emailed OS maps. However, I downloaded the Memory Maps app and couldn’t get the Walkhighlands GPX files to download to that either. When you click on Download, there is nowhere to download to. Where do these downloads go if there isn’t an app to select (other than using the View Ranger option)?
Posts: 4
Munros:33   Corbetts:15
Grahams:7   Donalds:11
Sub 2000:12   
Joined: Aug 20, 2010

Re: Gpx files in os maps

Postby Bramble » Thu Oct 24, 2019 10:38 am

I'm having similar issues. I even subscribed to premium os maps to see if that would help (it didn't).
I download the GPX file and instead of going straight to the os app it creates a small blue arrow at the top right of the screen. I click on the arrow and there are the walkhighlands GPX downloaded files - hoorah I thought as once I selected a download it opened my os app................but the download failed.I have logged out and reinstalled the app to no avail. I have used the os app without any problems until their September update. Now it is useless to me. :(

If anyone gets anywhere I would be interested to know.
Munro compleatist
Posts: 1
Munros:38   Corbetts:5
Sub 2000:9   
Joined: Feb 11, 2015

Re: Gpx files in os maps

Postby patbrechin » Fri Oct 25, 2019 8:09 pm

I have been in touch with OS Maps. Very helpful. Suggested I check I’m using most up to date version of the App (I am), suggesting opening OS maps before trying to download GPX files (did that), sent me a step by step list of how to download Walkhighlands walks - all of which I’ve done yet again, but all to no avail. I still cannot get the GPX files on Walkhighlands to download anywhere. All it says is ‘Download files’ and there is nowhere for them to go.

The guy at OS maps managed to download them successfully on his own iPad which suggests this is not affecting everyone. I just can’t understand why this has suddenly happened - about 3 weeks ago - and why it no longer works.

Has anyone out there had this issue and found a solution?
Posts: 4
Munros:33   Corbetts:15
Grahams:7   Donalds:11
Sub 2000:12   
Joined: Aug 20, 2010

Re: Gpx files in os maps

Postby Marty_JG » Fri Oct 25, 2019 10:39 pm

patbrechin wrote:When you click on Download, there is nowhere to download to. Where do these downloads go if there isn’t an app to select (other than using the View Ranger option)?

That's app dependent.

For example on my PC's Firefox Quantum browser there's a setting:

Code: Select all

[x] Save files to: c:\Downloads
[ ] Always ask where to save files

So one solution might to be to install a standard Browser on your phone and use that to download walk files.

You might also want to check for any download or local file storage settings for the Browser and the settings for your OS Maps app.
User avatar
Posts: 700
Munros:8   Corbetts:2
Sub 2000:3   
Joined: Sep 12, 2016
Location: Glasgow

Re: Gpx files in os maps

Postby patbrechin » Sat Oct 26, 2019 8:10 pm

Spoke to Apple Support at length about this problem today. It seems the update to iOS 13 contained security features which may be causing the problem. They suggested asking Walkhighlands and OS maps to check they are compatible with this updated operating system.
I’ve also had an exchange of emails with OS Maps who have tried really hard to find a solution and sent me the information below which I’ve tried and it works. So you have to go into Walk Highlands and download the walk on to your device. On the iPad and iPhone there is a small downward pointing arrow at the top right of the screen when you are on Safari. If you click on this you see what you have downloaded. To access the download you have to then go into the web version of OS Maps (not the App), and follow the instructions as described below. It’s a bit more cumbersome but at least will work till something’s done to enable walk GPX files to be downloaded directly from Walkhighlands to the OS Maps App.

Info from OS Maps:

To import a route on our web version

Save the route to your computer

Go to the OS Maps website, not the App, and log in. (Walkhighlands won’t allow the link to be put here)

Click on ‘Routes’ > ‘Import GPX’

Click ‘Choose file’ > select your file > click ‘Open’

Choose whether to make route private and click ‘Import route’

The route will be imported. Clicking on ‘Edit route’ will display the route and enable you to edit it. You can then save the changes.
Route will now be available from ‘Routes’ > ‘My Routes’ on the web version of OS Maps and will sync automatically to your app account (provided that you have logged into both with the same email and password)

I hope this helps and you can finally get these routes into your account.
Posts: 4
Munros:33   Corbetts:15
Grahams:7   Donalds:11
Sub 2000:12   
Joined: Aug 20, 2010

Re: Gpx files in os maps

Postby HeatherP78 » Thu Nov 28, 2019 11:47 pm

@patbrechin Thank you so much for putting up on how to be able to download routes as I have been having the same problem lately and I have tried everything to get it working the way it used to and everything failed until I tried your way and it worked. Thanks again.
Posts: 1
Munros:221   Corbetts:8
Grahams:1   Donalds:2
Sub 2000:11   
Joined: Aug 22, 2017

Re: Gpx files in os maps

Postby Ettaminnie » Sun Jan 05, 2020 12:38 am

Thank you for posting this @patbrechin , your fix works for me.
This has been driving me nuts for a few months now and I’m sure I’m not alone! Thanks again.
Posts: 1
Munros:43   Corbetts:12
Grahams:8   Donalds:2
Sub 2000:18   Hewitts:1
Joined: Jul 12, 2014

Re: Gpx files in os maps

Postby ochilbhoy » Wed Jan 22, 2020 8:34 pm

Have been having this problem as well, the web version has allowed me to add routes on os maps then it syncs with app, if using I phone go to your files app white background blue file icon any Walkhighlands gpx downloads usually go into this file,click on file by pressing finger on file and hold options will pop up go to bottom and click share this then has popped up options that frustratingly allowed me to download the route on to my old theMapFinder app route,comes up every time but always comes up failed on the new and improved (haha) os maps that you pay for , also gave option to open in viewranger some times the option copy to viewranger opened straight up to import setting so started using ViewRanger go into ViewRanger app click on three dots,scroll down to i import export, click on import this pops up the files you have already downloaded from walk highlands and wondered where they went, import file then go back to main settings and sync route should then be available in your routes section, hope this helps someone
Munro compleatist
Posts: 8
Munros:164   Corbetts:6
Grahams:2   Donalds:2
Joined: Oct 12, 2012

Walkhighlands community forum is advert free

We need help to keep the site online.
Can you help support Walkhighlands and the online community by setting up a monthly donation by direct debit?

Return to Help - how to use the site

Who is online

Users browsing this forum: No registered users and 2 guests